Chyba aktualizace z 3.2.8 na 3.3.0

Máte problémy s instalaci phpBB3 nebo s konverzi z phpBB2 na phpBB3? Zde naleznete pomoc.
Pravidla fóra
Čim více informací poskytnete ve vašem dotazu, tim vyšší je šance, že se vám dřív dostane přesné odpovědi. Uveďte odkaz na vaše fórum, používané rozšíření a styly a zkuste sepsat úpravy na fóru za poslední týdny. Nezapomeňte uvést výstižný titulek tématu.
Odpovědět
Radgost
Příspěvky: 40
Registrován: stř 12. lis 2008 12:25:23
Kontaktovat uživatele:

Chyba aktualizace z 3.2.8 na 3.3.0

Příspěvek od Radgost » stř 12. úno 2020 17:49:18

Zdravím,
při aktualizaci fóra z 3.2.8 na 3.3.0 instalace spadla a nyní se zobrazuje tato hláška.


Fatal error: Uncaught TypeError: Argument 1 passed to Symfony\Component\DependencyInjection\ContainerBuilder::addResource() must implement interface Symfony\Component\Config\Resource\ResourceInterface, instance of Symfony\Component\Config\Resource\FileResource given, called in /home/www/britva.cz/subdomains/forum/vendor/symfony/dependency-injection/ContainerBuilder.php on line 261 and defined in /home/www/britva.cz/subdomains/forum/vendor/symfony/dependency-injection/ContainerBuilder.php:203 Stack trace: #0 /home/www/britva.cz/subdomains/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(261): Symfony\Component\DependencyInjection\ContainerBuilder->addResource(Object(Symfony\Component\Config\Resource\FileResource)) #1 /home/www/britva.cz/subdomains/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(242): Symfony\Component\DependencyInjection\ContainerBuilder->addClassResource(Object(ReflectionClass)) #2 /home/www/britva.cz/subdomains/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(30 in /home/www/britva.cz/subdomains/forum/vendor/symfony/dependency-injection/ContainerBuilder.php on line 203

Složku vendor jsem obnovil ze zálohy, ale hláška zůstává.
Ví někdo co s tím?

x-rated
Příspěvky: 122
Registrován: pát 06. úno 2015 22:02:27
Bydliště: Praha
Kontaktovat uživatele:

Re: Chyba aktualizace z 3.2.8 na 3.3.0

Příspěvek od x-rated » stř 12. úno 2020 20:00:17

tady je přesnej postup krok za krokem, jak aktualizací bezpečně projít
https://www.phpbb.com/support/docs/en/3 ... upgrade32/

Radgost
Příspěvky: 40
Registrován: stř 12. lis 2008 12:25:23
Kontaktovat uživatele:

Re: Chyba aktualizace z 3.2.8 na 3.3.0

Příspěvek od Radgost » stř 12. úno 2020 22:04:20

Povedlo se.
Díky za radu!

jirys
Příspěvky: 50
Registrován: úte 05. bře 2013 8:51:39

Re: Chyba aktualizace z 3.2.8 na 3.3.0

Příspěvek od jirys » úte 03. bře 2020 17:38:32

funguje tato automatická aktualizace ?

Jak aktualizovat vaši instalaci pomocí „Automatického aktualizačního balíčku“

Odpovědět